Skip to main content
Procore (en-GB)

Android Requirements

 Important
The Procore Android app currently requires Android 9 or later. See the information below for details.

Updated Software Requirements for the Procore Android Mobile App

As we strive to provide the best experience for customers, we have ended support for Android 7.0 and 8.x as of February 1, 2022 and the software requirement has been updated to Android 9.0 or later. This means that in order to continue receiving the latest updates for the Procore app, you must have Android 9.0 or later running on your mobile device. After July 1, 2022, the Procore app will not be able to be downloaded to any mobile devices running Android 8.x or earlier.

Android 7 and 8 were released in 2016 and 2017. These operating systems are no longer supported by Google and do not receive new security updates from Google. 

What happens if my device is on an older version of Android?

While you can still use an older version of the Procore app if it was already downloaded to your device, we recommend using the latest versions of Android software and the Procore app for the best stability, security and feature compatibility. If your device remains on Android 8.x or earlier, you will not be able to upgrade to the newer app versions of Procore.

  • At a minimum, we recommend that you update your device to at least Android 9.0 (released in 2018) so that you can continue to receive Procore app updates.
  • If possible, update your supported device to Android 12 or 13 to maintain the highest level of support by both Android and Procore.
  • If you have a device not supported by Android 9 or later, you may consider replacing the device with one that is supported. 

How do I update my device?

For steps on how to update your device to a later version of Android, see Google's support article on checking and updating your Android version

See Also