Skip to main content
Procore (en-GB)

iOS Requirements

 Important
The Procore iOS app currently requires iOS 14 or later. See the information below for details.

Updated Software Requirements for the Procore iOS App

What happens if my device is on an older version of iOS?

How do I update my device?

See Also